The needed fix was implemented and tested. While the issue has been addressed, we will continue to monitor to ensure there is no regression. Please continue to monitor this page for further updates.
Posted Jul 01, 2026 - 10:54 EDT
Update
We are actively working on a solution to address this issue. It is a top priority and we are hoping to resolve it as soon as possible. Please continue to monitor this page for further updates.
Posted Jul 01, 2026 - 09:59 EDT
Investigating
We are aware of an issue affecting Salsa Engage where users are unable to send emails. We are currently investigating this issue. Please continue to monitor this page for further updates.