Salsa _ Issues with users unable to access Salsa Engage

Resolved

The incident has been successfully resolved.
Posted Mar 03, 2026 - 14:16 EST

Update

We are continuing to monitor for any further issues.
Posted Mar 03, 2026 - 14:15 EST

Monitoring

Access to Salsa Engage has resumed normal operations. Our team is continuing to monitor the system closely to ensure optimal performance.
Posted Mar 03, 2026 - 12:51 EST

Investigating

We are aware of an ongoing issue with users unable to access Salsa engage.
Posted Mar 03, 2026 - 11:41 EST
This incident affected: Salsa.