A fix has been implemented to address this issue. The images in the image gallery are now accessible and working as expected. Please note, images added earlier today will not be accessible, but will load as expected in any sent or draft emails. We apologize for any inconvenience caused to your organization and we will continue to monitor this closely to ensure there are no further issues. Please continue to monitor this page for further updates.
Posted Sep 23, 2025 - 18:17 EDT
Update
We are continuing to investigate this issue as a top priority. We expect to have a further update by tomorrow morning, so please continue to monitor this page for further updates.
Posted Sep 23, 2025 - 17:12 EDT
Investigating
Our team is actively investigating the issue to identify the root cause of email blast photos not appearing in File Manager. Please continue to monitor this page for further updates.