Penelope - Canada, US, UK - Emergency Maintenance

Scheduled for Sep 1, 01:00 - 04:00 EDT

Update

We will be undergoing scheduled maintenance during this time.
Posted Aug 26, 2026 - 07:06 EDT

Scheduled

Penelope in the US, UK and Canada will be undergoing Emergency Maintenance during this period in order to rectify a bug that can potentially cause an issue for some users. This is in addition to our regular scheduled maintenance in September.

During this period, users may encounter slowness or intermittent errors and we recommend, where feasible, that users wait until the maintenance completes.
Posted Aug 26, 2026 - 07:01 EDT
This scheduled maintenance affects: Penelope.