A fix has been implemented, tested and deployed. While the issue has been fully remediated, we will continue to monitor to ensure there is no regression. Please continue to monitor this page for additional updates.
Posted Apr 08, 2026 - 14:57 EDT
Identified
We are actively working on a fix to remediate the issue. This remains a top priority and we are expecting resolution as soon as possible. We apologize for the inconvenience and appreciate your continued patience. Please continue to monitor this page for further updates.
Posted Apr 08, 2026 - 09:42 EDT
Update
Our investigation remains underway as a top priority. We apologize for the inconvenience and appreciate your continued patience. Please continue to monitor this page for further updates.
Posted Apr 07, 2026 - 17:09 EDT
Update
We continue to work on a resolution as a top priority. We appreciate your patience and we hope to resolve this as soon as possible. Please continue to monitor this page for additional updates.
Posted Apr 07, 2026 - 12:16 EDT
Investigating
We are aware of issues users are currently experiencing with Salsa fundraising and peer to peer forms. We actively working toward a resolution as a top priority. Please continue to monitor this page for additional updates.