Submissions Delayed – Targeted Email & Online Actions

Resolved

The earlier issue affecting Targeted Email and Online Actions has been resolved. Submissions and statistics are now visible and up to date in the database.
Posted Apr 02, 2025 - 16:50 EDT

Update

We are continuing to investigate this issue.
Posted Apr 02, 2025 - 14:58 EDT

Investigating

We are currently investigating an issue affecting Targeted Email and Online Actions. Submissions are being recorded, but they are not currently visible in the database. Our team is actively working to resolve this and will provide an update as soon as the issue is resolved.
Posted Apr 02, 2025 - 14:30 EDT
This incident affected: EveryAction and NGP VAN.