WeSpire: Issue With Submitting Volunteer Hours

Resolved

This incident has been resolved.
Posted Jun 12, 2026 - 09:23 EDT

Monitoring

A fix has been implemented and successfully tested. While the issue has been remediated, we will monitor closely to ensure there is no regression. Please continue to monitor this page for further updates.
Posted Jun 11, 2026 - 18:03 EDT

Investigating

We are currently aware of an issue when attempting to submit volunteer hours and we are working on a resolution. Please monitor this page for updates.
Posted Jun 11, 2026 - 16:57 EDT
This incident affected: WeSpire.