The issue has been identified and the needed fix has been implemented. We are continuing to monitor to ensure there are no further issues or regression.
Posted Jul 01, 2025 - 13:07 EDT
Update
Our team is actively investigating the issue as a top priority. Please continue to monitor this page for further updates.
Posted Jul 01, 2025 - 11:35 EDT
Investigating
Apricot & ETO Connect Pages are currently experiencing errors and we are currently looking into the cause as a top priority.