We have identified the root cause of the issue, and our teams are actively implementing remediations. We will continue to monitor the situation closely and provide timely updates as we make progress
Posted Jul 09, 2025 - 10:04 EDT
Update
We are continuing to investigate the issue impacting deliverability. Please continue to monitor this page for further updates.
Posted Jul 08, 2025 - 17:10 EDT
Update
Our team is actively investigating the issue to identify the root cause and restore full deliverability as quickly as possible. Please continue to monitor this page for further updates.
Posted Jul 08, 2025 - 13:11 EDT
Investigating
We are currently experiencing reduced email deliverability with external email providers. Emails are still being sent successfully through Engage, but delivery to recipients may be inconsistent.