Apricot US user login issues

Resolved

The issue is now resolved.
Posted Apr 22, 2026 - 21:53 EDT

Monitoring

A fix has been implemented and we are monitoring to ensure stability.
Posted Apr 22, 2026 - 21:27 EDT

Identified

We are currently seeing some users encountering login issues for Apricot US. We have identified the issue and are working on resolution.
Posted Apr 22, 2026 - 20:31 EDT
This incident affected: Apricot.