ETO: Slowness Navigating ETO

Resolved

This incident has been resolved.
Posted Mar 03, 2025 - 16:31 EST

Investigating

Organizations are reporting slowness with navigating ETO. We are actively reviewing and monitoring performance.
Posted Mar 03, 2025 - 15:18 EST
This incident affected: ETO.