CyberGrants: CGDS Payment Transmission Issue

Resolved

The issue has been resolved and all impacted DAF payments have now been successfully transmitted.
Posted Mar 28, 2025 - 11:55 EDT

Investigating

An issue has been identified that has impacted the transmission of a few recent CGDS feeds for payments from the DAF account. While the development team is actively troubleshooting and addressing the issue, the team is also working on processing payments that may have been delayed/impacted by this issue. Please continue to monitor this page for further updates.
Posted Mar 28, 2025 - 10:45 EDT
This incident affected: CyberGrants.