Apricot: General Slowness Being Investigated

Identified

The root cause impacting Apricot slowness has been identified. A fix is scheduled to be deployed later this evening to remediate this issue. We apologize for any inconvenience. Please monitor this page for further updates.
Posted Sep 03, 2026 - 15:40 EDT

Investigating

We are aware that some users are currently experiencing slower than usual response times within the application, particularly on pages that rely on our API, such as Users/Roles, as well as with Alert Notifications. Our Engineering Team has identified the issue and is actively working on a resolution. We'll continue to post updates here as we learn more. We apologize for any inconvenience.
Posted Sep 03, 2026 - 15:11 EDT
This incident affects: Apricot.