Credit Card Processing Errors: Invalid Credit Card Verification Code (CVV)

Resolved

This incident has been resolved.
Posted Dec 02, 2025 - 21:00 EST

Monitoring

We are continuing to monitoring credit card giving activity to ensure there are no further issues. Please monitor this page for further updates.
Posted Dec 02, 2025 - 14:29 EST

Update

An update was implemented to address this issue. We are closely monitoring credit card giving activity to ensure there are no further issues. Please continue to monitor this page for further updates.
Posted Dec 02, 2025 - 13:30 EST

Investigating

We are currently investigating an issue with the submission of credit card donations associated with invalid credit card codes. We are still actively reviewing the issue, but we are seeing that the majority of errors are associated with donors using Google Chrome. While we are actively working on resolving this issue as soon as possible, donors can complete the donations using another browser, such as Microsoft Edge.

We apologize for any inconvenience and please monitor this page for further updates.
Posted Dec 02, 2025 - 12:39 EST
This incident affected: CyberGrants, GiveGab, and GiveGab Enterprise.