A fix has been successfully deployed and tested. While the issue has been resolved, and payee records can now be edited, we will continue to monitor closely to ensure there is no regression. We will post further updates tomorrow.
Posted Aug 13, 2026 - 22:04 EDT
Identified
The cause of the issue has been identified and we are currently preparing a solution that will be deployed later this evening, after 9 PM ET. We apologize for any inconvenience. Another update will be posted once this evening's deployment has been completed.
Posted Aug 13, 2026 - 16:07 EDT
Update
We are continuing our investigation as a top priority and we are working to resolve as soon as possible. Please continue to monitor this page for further updates.
Posted Aug 13, 2026 - 15:30 EDT
Update
At this time, we are still investigating the issue to identify the root cause and needed solution. We apologize for any inconvenience and we are working to remediate as quickly as possible. Please continue to monitor this page for further updates.
Posted Aug 13, 2026 - 14:46 EDT
Investigating
We are currently investigating an issue that is preventing some charities from editing payee details within customer specific agency portals. This issue is not impacting NPO Hub, and it is also not impacting all charities or all customer specific agency portals.
This is a top priority and we are working to resolve as quickly as possible. Please monitor this page for further updates.