We are continuing to investigate the issue. Updates will continue to be provided until resolution.
Posted Oct 04, 2024 - 16:46 EDT
Update
We are continuing to investigate the issue. Updates will continue to be provided until resolution.
Posted Oct 04, 2024 - 16:06 EDT
Update
We are continuing to investigate the issue. Updates will continue to be provided until resolution.
Posted Oct 04, 2024 - 15:36 EDT
Update
We are still investigating the issue causing some donors to be redirected to the login page, preventing them from completing their donation. Our team is working diligently to resolve this, and we will provide updates as soon as we have more information.
Posted Oct 04, 2024 - 15:05 EDT
Investigating
We are actively investigating an issue where some donors are being redirected to the login page, which is preventing them from completing their donations.