Critical Maintenance - GiveGab Core

Scheduled for Mar 6, 08:00 - 08:30 EST

Update

We will be undergoing scheduled maintenance during this time.
Posted Mar 02, 2026 - 13:49 EST

Scheduled

GiveGab Core will be undergoing critical maintenance on 2026-03-06 from 8:00-8:30am EST.

During this time users may encounter intermittent errors. Users are recommended to try their operation again or wait until the completion of the maintenance window.
Posted Mar 02, 2026 - 13:47 EST
This scheduled maintenance affects: GiveGab.