Intermittent errors and slowness navigating

Resolved

This incident has been resolved.
Posted Aug 21, 2025 - 17:33 EDT

Monitoring

There was an external network issue that was causing general performance slowness. The issue has been remediated and we are actively monitoring to ensure there are no further issues. Please continue to monitor this page for further updates.
Posted Aug 21, 2025 - 16:03 EDT

Update

We are aware of increased slowness and intermittent errors affecting the service and our team is actively investigating the issue. We’ll provide updates as more information becomes available.
Posted Aug 21, 2025 - 15:21 EDT

Investigating

We are aware of increased slowness and intermittent errors affecting the service and our team is actively investigating the issue. We’ll provide updates as more information becomes available.
Posted Aug 21, 2025 - 14:19 EDT
This incident affected: Apricot and CyberGrants.