Targeted Email Creation and Sending

Resolved

The earlier issue with an upstream provider has been resolved and users are now able to create, edit, and send in Targeted Email.
Posted Mar 08, 2025 - 12:43 EST

Investigating

Due to an issue with an upstream provider, users are unable to create, edit, or send in Targeted Email. We are investigating this issue.
Posted Mar 08, 2025 - 12:15 EST
This incident affected: NGP VAN.