NPO Hub is Not Accessible

Monitoring

A fix has been implemented and successfully tested. NPO Hub is now accessible, but you may need to clear your cache if you experience any errors. Cache clearing instructions are provided below:

Google Chrome (Desktop)
Go to Settings > Privacy and security > Third-party cookies.
Select See all site data and permissions.
Search for the website name in the top-right search bar.
Click the Delete (trash can) icon next to the site and confirm.

Microsoft Edge
Go to Settings > Cookies and site permissions > Manage and delete cookies and site data.
Select See all cookies and site data.
Search for the site and click the down arrow to its right, then select Delete.

Mozilla Firefox
Go to Settings > Privacy & Security.
Find the Cookies and Site Data section and click Manage Data....
Search for the website, select it, and click Remove Selected (or Remove All Shown).
Click Save Changes and confirm

Safari (Mac)
In the menu bar, choose Safari > Settings (or Preferences).
Click the Privacy tab, then click Manage Website Data....
Search for the website, select it, and click Remove

Mobile (Android & iOS)
Chrome (Android): Open the site, tap the Page info icon (three dots or padlock) in the address bar, then select Cookies and site data > Delete.
Safari (iPhone/iPad): Go to Settings > Safari > Advanced > Website Data. Search for the site, swipe left on its name, and tap Delete

We will continue to monitor closely to ensure there are no further issues, but please continue to view this page for further updates.
Posted Jun 01, 2026 - 19:46 EDT

Update

We are continuing to investigate this issue.
Posted Jun 01, 2026 - 15:55 EDT

Investigating

We are currently addressing an issue that is blocking users from accessing NPO Hub. We are working to remediate this as soon as possible. Please monitor this page for updates.
Posted Jun 01, 2026 - 15:55 EDT
This incident affects: Nonprofit Hub.