Salsa _ Service Disruption Notice on certain forms

Update

We have found the source of this issue and are doing everything we can to get it resolved as quickly as possible. We appreciate your continued patience and ask that you monitor this page for the latest updates.
Posted Sep 21, 2026 - 16:18 EDT

Update

The root cause of this issue has been identified and we are taking immediate steps to implement a resolution. We appreciate your continued patience and ask that you monitor this page for the latest updates.

Next update will be posted at approximately 3:30 PM ET, if not sooner.
Posted Sep 21, 2026 - 14:36 EDT

Identified

We have identified the root cause of the issue and we are actively working on a solution. Thank you for your continued patience. Please continue to monitor this page for further updates.

Next update will be posted at approximately 2:30 PM ET, if not sooner.
Posted Sep 21, 2026 - 13:30 EDT

Update

Our team is actively working to resolve this issue and it remains our top priority. We appreciate your patience and ask that you continue to check this page for the latest updates.

Our next update will be posted by approximately 1:30 PM ET, if not earlier.
Posted Sep 21, 2026 - 12:30 EDT

Update

We are continuing to review this issue as a top priority. Thank you for your patience and please continue to monitor this page for further updates.

Next update will be posted at approximately 12:30 AM ET, if not sooner.
Posted Sep 21, 2026 - 11:21 EDT

Investigating

We have identified some disruption on certain forms and are actively investigating. We'll share updates here as we have more information.

Next update will be posted at approximately 11:00 AM ET, if not sooner.
Posted Sep 21, 2026 - 10:33 EDT
This incident affects: Salsa.