Nonprofit Hub is live

Update

Processing performance is improving. Most requests are completing normally, though some actions may still take longer than usual—no need to resubmit. We’ll post updates here until processing is fully back to normal.
Posted Sep 29, 2025 - 16:02 EDT

Investigating

Nonprofit Hub is live! As we complete the rollout, certain actions may take longer than usual. Your requests are queued and will complete, no need to resubmit. We will post updates here as processing returns to normal.
Posted Sep 29, 2025 - 09:49 EDT
This incident affects: Nonprofit Hub.