A fix has been implemented to address the issue. We will continue to monitor to ensure there is no regression. Please continue to monitor this page for further updates.
Posted May 15, 2026 - 10:29 EDT
Update
As we work to resolve this issue, you may experience a slight disruption. Please monitor this page for further updates.
Posted May 15, 2026 - 10:05 EDT
Investigating
We are aware of an ongoing issue that is impacting some users from being able to access Salsa CRM. Our engineers are actively investigating this and working to resolve this issue. Please monitor this page for further updates.