Salsa: Email Stats Not Populating

Update

Our team is continuing to work on a resolution to address this issue. We will provide updates as more information becomes available.
Posted Apr 25, 2025 - 09:04 EDT

Investigating

We have identified an issue affecting some customers where email delivery visibility is not displaying accurately in Engage. Our team is actively investigating and working to resolve the issue. We will provide updates as more information becomes available.
Posted Apr 24, 2025 - 16:45 EDT
This incident affects: Salsa.