Apricot and ETO- Intake Links Unresponsive or Experiencing Slowness

Postmortem

Issue Summary: On Wednesday 21st January 2026, at approximately 0803 ET, we became aware that for some users, Apricot Intake Form links were either unresponsive or very slow to respond. This prevented affected users from submitting Intake Forms. After investigation and remediation of a bottleneck, normal service resumed at approximately 0930 ET.

Root Cause: Analysis showed that at 0800 ET, Intake Form traffic spiked to between 10 and 50 times historically normal levels causing the infrastructure handling those forms, to quickly become overwhelmed and slow down considerably. The kinds of levels the traffic scaled to, and the speed at which it did, was unprecedented. Manual intervention was required and when sufficient capacity was freed up, normal service resumed.

Prevention: Auto-scaling on the Intake Portal servers had not been enabled, primarily due to the relative stability of traffic historically and the fact that it was not possible to deploy concurrent version of the application. This concurrency limitation has now been fixed, and we will shortly be implementing auto-scaling measures to prevent such issues recurring.

Posted Feb 05, 2026 - 09:02 EST

Resolved

The incident has been successfully resolved.
Posted Jan 21, 2026 - 13:30 EST

Monitoring

Apricot and ETO Connect are back to normal operations. We’re continuing to monitor the systems to ensure stable performance.
Posted Jan 21, 2026 - 10:02 EST

Investigating

We are currently investigating an issue affecting Apricot and ETO Connect, including admin-facing console, portal login, and external Intake Forms, for clients in the US Our team is actively working to restore access and will share updates as they become available.
Posted Jan 21, 2026 - 09:10 EST
This incident affected: Apricot and ETO.