User Issues With Submitting Event Registrations in Salsa Engage

Resolved

This incident has been resolved.
Posted Apr 06, 2026 - 13:15 EDT

Monitoring

A fix has been implemented, tested, and deployed. We will continue to monitor to ensure there are no further issues. Please monitor this page for further updates.
Posted Apr 06, 2026 - 12:13 EDT

Investigating

We are aware of an ongoing issue with users unable to submit registrations to events in Salsa engage. This is a top priority and we are working to remediate as quickly as possible. Please monitor this page for updates.
Posted Apr 06, 2026 - 10:22 EDT
This incident affected: Salsa.