Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 19, 2024 - 01:30 EDT
Update
We will be undergoing scheduled maintenance during this time.
Posted Oct 10, 2024 - 15:05 EDT
Scheduled
On Sat, Oct 19 at 1:30am EDT, Salsa systems will be undergoing system maintenance. During this time, Salsa customers may experience their platform being unavailable for a maximum of two hours. There should be no impact on data. Salsa customers do not need to do anything before, during, or after this maintenance.