WeSpire: Issue With Organization Search Function for Logging Hours

Update

We are still working on a resolution to address this issue. We apologize for the impact and appreciate your patience as we continue to implement a fix. Please continue to monitor this page for further updates.
Posted Jun 11, 2026 - 14:12 EDT

Investigating

We are currently aware of an issue with searching for organizations by address, when logging volunteer hours. This is a top priority and we are working to resolve the issue as soon as possible. Please monitor this page for further updates.
Posted Jun 11, 2026 - 11:01 EDT
This incident affects: WeSpire.