EveryAction Experiencing Contact Record Errors
Resolved
This incident has been resolved.
Posted Nov 20, 2024 - 14:02 EST
Investigating
We are currently aware of an issue impacting the ability to view contact records for some users. Our team is actively investigating the cause and working diligently to resolve it as quickly as possible.
Posted Nov 20, 2024 - 13:38 EST
This incident affected: EveryAction.