Apricot: Reported Login Issues

Resolved

This incident has been resolved.
Posted May 11, 2026 - 16:18 EDT

Investigating

We are currently investigating an issue that is blocking access into Apricot for specific customers. We are reviewing this as a top priority and working to remediate as soon as possible. Please monitor this page for further updates.
Posted May 11, 2026 - 15:54 EDT
This incident affected: Apricot.