Issue with Mobile Messaging Reporting

Resolved

As of 5:10 PM ET, we have resolved the earlier issue that caused some users to experience a delay in reporting for Mobile Messaging. Reporting for any messages sent from 5:10PM ET on should be working as normal. We are working on updating the reporting for previously sent Mobile Messages that had a delay in reporting. We are continuing to monitor for any further issues.
Posted Mar 11, 2026 - 17:17 EDT

Investigating

We are currently investigating an issue that is causing a delay in reporting for Mobile Messaging. We are working as quickly as possible to resolve this and will share an update as soon as we have one.
Posted Mar 11, 2026 - 16:17 EDT
This incident affected: EveryAction and NGP VAN.