Penelope is experiencing intermittent disruptions

Resolved

The incident has been successfully resolved.
Posted Jun 16, 2026 - 11:04 EDT

Update

We are actively working on resolving the issue and expect it to be fully resolved in the next 24 hours.
Posted Jun 15, 2026 - 12:25 EDT

Identified

The cause of the issue has been identified, and our team is actively implementing a solution.
Posted Jun 15, 2026 - 01:24 EDT

Investigating

As of 8:00 AM AEST, Penelope is experiencing intermittent disruptions for some users in the Australia and New Zealand regions. We will provide an update and an estimated time for resolution as soon as possible.
Posted Jun 15, 2026 - 00:46 EDT
This incident affected: Penelope.