A fix was deployed last night to remediate the performance issues. While performance has returned to normal, we will continue to monitor closely to ensure there is no regression.
Posted Aug 07, 2026 - 11:36 EDT
Identified
An additional fix is scheduled to be deployed this evening to assist with current performance issues. We appreciate your patience and ask that you continue to monitor this page for additional updates.
Posted Aug 06, 2026 - 15:57 EDT
Investigating
An update was deployed to remediate the issue. While we are seeing some performance improvements, we are continuing to investigate the root cause to address further. Please monitor this page for further updates.
Posted Aug 06, 2026 - 10:41 EDT
Update
We remain active with the implementation of the needed fix to remediate the issue. We appreciate your patience and ask that you continue to monitor this page for additional updates.
Posted Aug 06, 2026 - 09:17 EDT
Identified
The root cause of the issue has been identified and a solution is currently being prepared. The needed fix will be deployed no later than tomorrow morning to fully remediate the performance issues. Please continue to monitor this page for further updates.
Posted Aug 05, 2026 - 18:46 EDT
Update
We are continuing our investigating into this issue and hoping to remediate as soon as possible. Please monitor this page for further updates.
Posted Aug 05, 2026 - 18:12 EDT
Update
Our team is still investigating the issue impacting Apricot performance and we are working to resolve it as soon as possible. Please continue to monitor this page for further updates.
Posted Aug 05, 2026 - 17:10 EDT
Update
We are actively reviewing this issue and it remains our top priority. We appreciate your patience and ask that you continue to monitor this page for the latest information.
Our next update will be posted by approximately 5:00 PM ET, if not sooner.
Posted Aug 05, 2026 - 16:37 EDT
Investigating
We are actively investigating an issue that is causing intermittent errors and slowness when accessing specific Apricot pages. We are reviewing this issue as a high priority and working to address as quickly as possible. Please monitor this page for further updates.