A fix has been implemented, tested, and deployed. We have confirmed that the ticketed event and fundraising pages are now loading without issue. We will continue to monitor to ensure there are no further issues. Further updates will be posted to this page.
Posted Jan 27, 2026 - 14:21 EST
Identified
The issue has been identified and our development team is actively working on implementing the needed fix. Please continue to monitor this page for further updates.
Posted Jan 27, 2026 - 11:54 EST
Investigating
We have received reports of Salsa ticketed event and fundraising pages not loading. Our team is currently reviewing as a top priority and working to remediate as soon as possible. Please continue to monitor this page for further updates.