Cloudflare has remediated the external issue and traffic has returned to normal. We will continue to monitor to ensure there is no regression. Please continue to monitor this page for additional updates.
Posted Jun 22, 2026 - 13:33 EDT
Identified
Cloudflare is reporting an issue that is impacting traffic. Some users connecting in North America, or accessing services in Europe, may see connection issues and increased latency.
While the Apricot and ETO applications are up and running, users may be impacted based on the external issue reported by Cloudflare. We will provide further updates as they become available from Cloudflare, but you can also monitor Cloudflare's Status Page at: https://www.cloudflarestatus.com.
Posted Jun 22, 2026 - 11:35 EDT
Investigating
We are actively investigating reported issues impacting user login and general slowness on both the Apricot and ETO applications. This is being reviewed as a top priority. Please monitor this page for additional updates.