Users Experiencing Login Issues in CyberGrants

Postmortem

Issue Summary:

On April 9th, 2026, a planned production deployment to CyberGrants introduced a code defect that caused Single Sign-On (SSO) to return errors for some users. Affected users were unable to log in via SSO during the disruption window. A rollback was initiated to restore normal service.

Root Cause:

An edge case was identified in the SSO handler where a required dependency did not load correctly in the production environment following the deployment. This caused SSO authentication requests to fail for a subset of users. The defect was not surfaced during pre-production testing due to the environmental conditions required to trigger the edge case.

Prevention:

We rolled back the deployment to restore SSO functionality for all affected users. We are currently reviewing and thoroughly testing the SSO handler in non-production environments to identify and resolve the edge case before re-deploying. Additional testing coverage will be introduced to better simulate production conditions and prevent recurrence.

Posted Apr 15, 2026 - 09:09 EDT

Resolved

This incident has been resolved.
Posted Apr 10, 2026 - 08:52 EDT

Monitoring

The issue affecting user logins to CyberGrants has been resolved. We will continue to monitor the platform to ensure there are no further disruptions.
Posted Apr 10, 2026 - 08:11 EDT

Investigating

We are experiencing an issue with donors and users logging into the CyberGrants platform. We are investigating this issue and will have an update shortly.
Posted Apr 10, 2026 - 07:57 EDT
This incident affected: CyberGrants.