Apricot & ETO: General Slowness and Performance Issues

Resolved

The incident has been successfully resolved.
Posted Aug 17, 2026 - 16:37 EDT

Monitoring

We have implemented a fix and have completed testing. While the issue has been addressed, we will continue to monitor to ensure there is no regression. Please continue to monitor this page for further updates.
Posted Aug 17, 2026 - 13:22 EDT

Update

We are continuing our review to identify the root cause impacting Apricot & ETO general slowness and performance delays. This is a top priority and we are working to resolve as soon as possible. Please continue to monitor this page for further updates.

Next update will be posted at approximately 1:15 PM ET, if not sooner.
Posted Aug 17, 2026 - 12:47 EDT

Update

We are continuing to investigate this issue.
Posted Aug 17, 2026 - 12:24 EDT

Investigating

We are actively investigating an issue that is causing general slowness and performance delays throughout the Apricot & ETO applications. This is a top priority and we are working to resolve as soon as possible. Please continue to monitor this page for further updates.

Next update will be posted no later than 12:45 PM ET.
Posted Aug 17, 2026 - 12:15 EDT
This incident affected: Apricot and ETO.