We have implemented a fix and have completed testing. While the issue has been addressed, we will continue to monitor to ensure there is no regression. Please continue to monitor this page for further updates.
Posted Aug 27, 2026 - 10:35 EDT
Update
We are continuing to investigate some remaining latency/slowness when performing searches on Sandbox. Please continue to monitor this page for further updates. We will provide another update around 10:30am EST
Posted Aug 27, 2026 - 10:02 EDT
Investigating
We are aware of an issue currently impacting performance in Cybergrants Sandbox. We understand the disruption this may cause and want to assure you that this is our top priority.