Disclosure Report Generation

Resolved

As of 2:20PM ET, the earlier issue that caused users to not be able to generate disclosure reports has been resolved. We are continuing to monitor for any further issues.
Posted Jan 28, 2026 - 14:22 EST

Investigating

We are currently investigating an issue that is causing users to be unable to generate disclosure reports. This will appear as if the report is generating for longer than expected. We are looking into the underlying cause and will share an update as soon as we have one.
Posted Jan 28, 2026 - 13:46 EST
This incident affected: NGP VAN.