As of 3:18 PM EST, all systems are back online and are being actively monitored. Our checks confirm that URLs are responding and DNS resolution has been restored.
Posted Feb 10, 2026 - 15:36 EST
Update
The upstream provider has indicated that most services have been restored, and conditions are stabilizing for GiveGab Enterprise customers. Due to DNS propagation, some intermittent errors may still occur as updates continue to propagate globally. We are still observing occasional DNS resolution errors, though they are now significantly less frequent and may not be noticeable to customers.
Posted Feb 10, 2026 - 15:06 EST
Monitoring
We are aware that GiveGab Enterprise may be experiencing intermittent loading issues. This appears to be related to an issue with a downstream service provider. Our team is actively investigating and monitoring system performance. We will provide updates as more information becomes available.