Network for Good: Chat Function Not Available

Resolved

This incident has been resolved.
Posted Apr 21, 2025 - 14:39 EDT

Monitoring

The issue has been identified and a fix has been implemented. The chat function is currently available and operational, but we will continue to monitor.
Posted Apr 21, 2025 - 13:38 EDT

Investigating

We are currently investigating an issue that is preventing the support chat functionality from be accessible. Please monitor this page for further updates.
Posted Apr 21, 2025 - 12:09 EDT
This incident affected: Network for Good.