Apricot: Issue with Accessing Documents

Resolved

This incident has been resolved.
Posted Jun 18, 2026 - 19:00 EDT

Identified

The root cause has been identified and a fix is scheduled to be deployed this evening. Please continue to monitor this page for further updates.
Posted Jun 18, 2026 - 14:36 EDT

Investigating

We are currently investigating an issue that is impacting some users from accessing documents. This is a top priority and we are working to resolve as soon as possible. Please monitor this page for further updates.
Posted Jun 18, 2026 - 14:10 EDT
This incident affected: Apricot.