Salsa: Issues with Loading Multiple Pages within Engage

Resolved

This incident has been resolved.
Posted Feb 23, 2026 - 17:52 EST

Investigating

We are aware of an ongoing issue with users unable to load multiple pages within Engage including the ability to edit emails and forms. We are actively reviewing this as a top priority. Please monitor this page for further updates.
Posted Feb 23, 2026 - 16:55 EST
This incident affected: Salsa.